Система "Бенукс". Компьютерное управление и контроль.

решение вопросов по система "Бенукс"
Текущее время: 31-07, 03:09

Часовой пояс: UTC + 3 часа




Начать новую тему Ответить на тему  [ Сообщений: 10 ] 
Автор Сообщение
 Заголовок сообщения: Ошибка
СообщениеДобавлено: 10-10, 07:03 
Не в сети

Зарегистрирован: 19-05, 14:54
Сообщения: 25
Геннадий, день добрый!

Вопрос к Вам. Поставили триалку Бенукса на виртуальную 7-ку (32бит). Время от времени вылетает ошибка "Failed to set data for 'sys_st' ". Пока ошибка висит на экране и пользователь не нажмет кнопку ОК, замер температуры термометров останавливается. Что это такое и как с этим бороться? (Бенукс 6.55)

Заранее спасибо!

PS Может быть стоит завести отдельную ветку (или тему) и в ней собирать все возникающие ошибки и их решения?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Ошибка
СообщениеДобавлено: 10-10, 12:13 
Не в сети

Зарегистрирован: 19-05, 14:54
Сообщения: 25
А нет - вру. Данные продолжают собираться. Но в любом случае интересно, чем вызвана ошибка


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Ошибка
СообщениеДобавлено: 11-10, 08:00 
Не в сети
Site Admin

Зарегистрирован: 14-10, 14:58
Сообщения: 488
booyaka писал(а):
вылетает ошибка "Failed to set data for 'sys_st' ".
Возможно, не хватает прав доступа. Сообщите, пожалуйста с какими правами запускается программа?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Ошибка
СообщениеДобавлено: 11-10, 08:41 
Не в сети

Зарегистрирован: 19-05, 14:54
Сообщения: 25
На виртуальной машине только одна учетка и она с правами администратора. Как был ранее произведен запуск Бенукса не знаю. Сейчас его перезапустили уже наверняка от имени администратора. Посмотрим, что будет.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Ошибка
СообщениеДобавлено: 12-10, 10:40 
Не в сети

Зарегистрирован: 19-05, 14:54
Сообщения: 25
Да, Вы видимо были правы. Запустив Бенукс от имени администратора, ошибка перестала появляться.

Однако появился еще один вопрос - в прежних версиях Бенукса график температуры отрисовывался за весь указанный в настройках период (кол-во часов по оси Х). Теперь почему-то отображаются лишь последние 4 часа (или около того). Подскажите пожалуйста, можно ли изменить этот интервал?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Ошибка
СообщениеДобавлено: 12-10, 11:20 
Не в сети
Site Admin

Зарегистрирован: 14-10, 14:58
Сообщения: 488
booyaka писал(а):
в прежних версиях Бенукса график температуры отрисовывался за весь указанный в настройках период (кол-во часов по оси Х). Теперь почему-то отображаются лишь последние 4 часа (или около того).
В этой части программы изменений никаких не было. Что касается отображения графика, должен заметить, что на это влияет не только настройка по оси Х, но и настройка буфера FIFO. Возможно здесь у Вас какие-то изменения настроек.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Ошибка
СообщениеДобавлено: 12-10, 11:40 
Не в сети

Зарегистрирован: 19-05, 14:54
Сообщения: 25
В настройках задано отображение за 12 часов. Размер буфера FIFO меняется автоматом при изменении количества часов и для 12 часов составляет 108 000. При этих установках отрисовываются последние 4 часа. Увеличил буфер FIFO в десять раз - посмотрим что будет.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Ошибка
СообщениеДобавлено: 13-10, 06:31 
Не в сети

Зарегистрирован: 19-05, 14:54
Сообщения: 25
Изображение
Ничего не поменялось от увеличения в 10 раз буфера FIFO. Есть идеи куда копать?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Ошибка
СообщениеДобавлено: 13-10, 09:17 
Не в сети
Site Admin

Зарегистрирован: 14-10, 14:58
Сообщения: 488
booyaka писал(а):
Ничего не поменялось от увеличения в 10 раз буфера FIFO. Есть идеи куда копать?
Поставьте галку "из оси X", перезапустите программу и начните сканирование с начала.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Ошибка
СообщениеДобавлено: 14-10, 07:22 
Не в сети

Зарегистрирован: 19-05, 14:54
Сообщения: 25
Была еще проблема со шрифтами. На русской раскладке вместо привычных символов печатались "???????". Обе проблемы решились после перезапуска. Галку не ставил. Геннадий, спасибо!


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 10 ] 

Часовой пояс: UTC + 3 часа


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 0


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения

Найти:
Перейти:  

cron
Powered by Forumenko © 2006–2014
Русская поддержка phpBB